Active Sky Next – Service Pack 4 Beta

Logo_ASN1Take advantage of the new Service Pack 4 Beta for Active Sky Next, as it fixes potential issues with SimConnect, ASConnect and adds the P3D V3 compatibility.

For FSX users, they will get rid of any API radar errors or other “invalid simconnect version” message. Find their full announcement here.

Comments are closed.