FSX

FSUIPC 4.931

Dowson-FSUIPC4n3

Required for Prepar3D v2.2, the latest version of FSUPIC 4.931 can be downloaded from Pete Dowson“s forum here.

Obviously, it may be useful for FSX users as well so always use the newest version available so you can get support, take advantage of the latest features and fixes to avoid any problem or compatibility issue.

Comments are closed.