FSX

FSUIPC – Download Prepar3D v3

fsmodules

Pete Dowson of FSUIPC is back from his break and has already pushed the update v4.946 of FSUIPC. The update is compatible for FSX, FSX-SE and Prepar3D versions 1.4, 2.0-2.5 and 3.0 so if you are currently running the new Prepar3D v3, then you should certainly get this update. To download your updated (and compatible) updated version for v3, head over the the updated post.

Comments are closed.