Service Pack 1 for Coolsky DC-9


SP1 CoolSkyAfter 4 unofficial beta patches, the final Service Pack 1 is ready for the best ‘vintage tubeliner’ on FSX.

Note: you have to uninstall the add-on first. Visit Flight1 for more infos.

newest oldest most voted
Notify of

Thank you Sebastián .

Question: let’s say after I uninstall the flight1 DC-9 and install the new flight1DC-9 SP1 .Do I need to install all the betas patch again.

Thank you